xRDP with GNOME Desktop working for CentOS

Note: SkySilk's tutorial was not working at the time I wrote this. Theirs has since been updated, this guide may or may not work for you. Please refer to their official guide for xRDP setup.


Hello everyone this is an updated tutorial on how to get a desktop environment on your vps so follow these steps:


Step 1: Install xRDP

yum install xrdp


Step 2: start xRDP

systemctl start xrdp


Step 3: Install the desktop

yum -y groups install "GNOME Desktop"


Step 4: Remote desktop connect to your vps and enjoy


Regarding your last note, our xRDP article has been updated for Ubuntu 18.04 only, all other versions and Linux distros would not apply.

 For a opensuse42.2 which I created , I could do as root user the following for steps 1,2,3

(after the initial default installation of course there is no desktop installed by default , although I found that the systemd target is : 

# systemctl get-default

graphical.target  )

# zypper install xrdp

# systemctl enable xrdp 

# systemctl start xrdp

# zypper install patterns-openSUSE-gnome


But I do not know what modifications should be done (if any) on the file

/etc/xrdp/startwm.sh

and also since I do not have a Windows laptop I do not have RemoteDesktop  to use to connect on my VPS. 

But anyway , when I connect as root to my opensuse42.2 VPS , after rebooting it, I still see that there are many dependencies not satisfied by issuing this command

# systemctl list-dependencies

so it seems that the desktop environment has not yet started, and more things need to be done.

Login or Signup to post a comment